Endpoint Central オンプレミス版 ナレッジベース

指定されたネットワークのパスを容認したネットワークプロバイダはありません


「指定されたネットワークのパスを容認したネットワークプロバイダは一つもありません」(指定されたネットワークパスはどのネットワークプロバイダーも受け付けられません)

問題
Desktop Centralエージェントのインストール、パッチスキャン、リモート制御を実行しようとすると、次のエラーが発生し、実行が失敗します。 「指定されたネットワークのパスを容認したネットワークプロバイダはありません」「指定されたネットワークパスはどのネットワークプロバイダーによっても受け付けられませんでした」(No network provider accepted the given network path)  
原因
次のいずれか、またはいずれか複数の理由により、このエラーが発生します;
  1. クライアントPCの管理共有(admin$)にアクセスできない
  2. FQDNでクライアントPCにPingできない
  3. 「Microsoft用ネットワーク用ファイルとプリンター共有」が有効化されていない
  4. 「ファイルとプリンターの共有」がクライアントPCのWindowsファイアウォールで無効化されている
  5. セキュリティポリシーが設定されていない
  6. TCP/IP NetBIOS HelperサービスがクライアントPCで稼働していない
  7. クライアントPCのファイアウォールで必要なポートが開いていない
本ページで提供する原因と解決策は、本製品開発時およびクライアント環境上での経験に基づいています。そのため、本ページでは説明していない問題要因によって操作が失敗している可能性があります。
  • Active Directory環境でのエージェントインストールの場合 GPOスクリプトを使用したエージェントインストールも合わせてご検討ください。
  • 手動パッチスキャン/手動インベントリスキャンの場合 スケジュールスキャンを実行することを推奨します。
 
解決策
次の解決策に従ってください。
1. クライアントPCの管理共有(admin$)にアクセスできない
クライアントPCの管理共有へのアクセスを確認します。
  1. Desktop Centralサーバーがインストールされているコンピューターにおいて、「スタート」> 「ファイル名を指定して実行」を開きます。
  2. 「\\<クライアントPC名>\admin$」と入力します
  3. 「OK」をクリックします
同じエラーがまだ発生し続ける場合、クライアントPCで「リモート管理の例外」オプションを有効にします。「リモート管理の例外」オプションを有効にするには、次の手順に従ってください。
  1. クライアントシステムで、「スタート」>「ファイル名を指定して実行」を選択します
  2. 「gpedit.msc」と入力します
  3. 「OK」をクリックします
  4. 「管理用テンプレート」を拡げ、「ネットワーク」>「ネットワーク接続」>「Windowsファイアウォール」を選択します
  5. 「ドメインプロファイル」をクリックします
  6. 「Windowsファイアウォール」をダブルクリックし、リモート管理の例外を選択します
  7. 「有効」を選択し、「OK」をクリックします
 
2. FQDN(完全修飾ドメイン名)を使用してクライアントPCにPingする
FQDNを使用してDesktop CentralサーバーがインストールされているサーバーからクライアントPCにPingできることを確認します。
(例) ping hostname.example.com
 
3. 「Microsoftネットワーク用ファイルとプリンター共有」を有効化する
クライアントPCにおいて、「ファイルとプリンターの共有」を有効にする必要があります。
  1. 「スタート」>「コントロールパネル」>「ネットワークとインターネット」>「ネットワーク接続」をクリックします
  2. 接続しているネットワークのアイコンを右クリックし、「プロパティ」を選択します
  3. 「プロパティ」ダイアログボックスにおいて、「一般」タブを選択します
  4. Microsoftネットワーク用ファイルとプリンター共有のチェックボックスを選択します
  5. 「OK」をクリックします
このオプションが見つからない場合、「ファイルとプリンター共有」のオプションをインストールする必要があります。
 
4. クライアントPCのWindowsファイアウォールにおいて、「ファイルとプリンターの共有」を有効にする
クライアントPCのWindowsファイアウォールにおいて、「ファイルとプリンター共有」オプションを有効にする必要があります。
  1. 「スタート」>「設定」>「コントロールパネル」>「Windowsファイアウォール」を選択します
  2. 「例外」タブを選択します
  3. 「ファイルとプリンター共有」チェックボックスを選択します
  4. 「OK」をクリックします
それでも「指定されたネットワークパスはどのネットワークプロバイダーも受け付けられません」というエラーが発生し続ける場合、次の内容を確認してください。
  • Desktop Centralサーバーのコンピューターが使用している同じプロファイル上で、「ファイルとプリンターの共有オプション」を設定しているかどうか
  • Desktop Centralがインストールされたプロファイルを使用しているかどうか(ドメインで「ファイルとプリンター共有」オプションを有効にする際、使用するプロファイルがDesktop Centralインストール時に使用するプロファイルと異なる場合があります。この場合、「ファイルとプリンター共有」オプションが通常のプロファイルで有効化されていない可能性があります。)
netshコマンドを使用すると、次の情報を確認できます。
  • Desktop Centralインストール時に使用するシステムプロファイル
  • 「ファイルとプリンター共有」オプションを有効にする際使用するプロファイル
あるいは、「ファイルとプリンター共有」オプションをすべてのプロファイルに対して有効化できます。
  1. 「スタート」>「コマンドプロンプト」を選択します
  2. 次のように入力します
    netsh firewall set service type = FILEANDPRINT mode = ENABLE scope = ALL profile = ALL
  3. 「Enter」を押します
これで「ファイルとプリンター共有」オプションをすべてのプロファイルに設定できます。  
5. セキュリティポリシーを設定する
システムでセキュリティポリシーを設定するには、次の手順に従ってください;
  1. 「スタート」>「設定」>「コントロールパネル」>「管理ツール」をクリックします
  2. 「ローカルセキュリティポリシー」>「ローカルポリシー」>「セキュリティオプション」をダブルクリックします。
  3. 「ネットワークセキュリティ」:LANマネージャー認証レベルをダブルクリックします
  4. 「LMとNTLM応答を送信する」を選択します
  5. 「OK」をクリックします
これでシステム上にセキュリティポリシーを設定できます。  
6. クライアントコンピューターで「TCP/IP NetBIOS Helperサービス」を開始する
  1. 「設定」>「コントロールパネル」>「管理ツール」>「サービス」を選択します
  2. 「TCP/IP NetBIOS Helper」>「スタート」を右クリックします
これで「TCP/IP NetBIOS helperサービス」をクライアントコンピューターで開始することができます。  
7. 必要なポートを開く
クライアントシステムのファイアウォールにおいて、次のポートを開いてください。
  • 135
  • 139
  • 445